Grow Your Business Online.
Submit a ticket My Tickets
Welcome
Login  Sign up

Announcement - Let’s Encrypt DST Root CA X3 Expiration

Dear valued customer,


One of the Certificate Authority providing TLS certificates, Let’s Encrypt has a root certificate expires on 30-Sep-2021.


Who will be affected? 

Basically no one, except Users who are using older devices / browsers software.


Below is a list of OS and web clients that will be affected:

  • OpenSSL <= 1.0.2
  • Windows < XP SP3 (assuming Automatic Root Certificate Update isn’t manually disabled)
  • macOS < 10.12.1 (year 2016)
  • iOS < 10 (iPhone 5 is the lowest model that can get to iOS 10)
  • Android < 7.1.1 (but >= 2.3.6 will work if served ISRG Root X1 cross-sign)
  • Mozilla Firefox < 50
  • Ubuntu < 16.04
  • Debian < 8
  • Java 8 < 8u141
  • Java 7 < 7u151
  • NSS < 3.26
  • Amazon FireOS (Silk Browser)


What will be the impact? 

Visitors on outdated browser versions will see the page that reads “this connection is not secure” or a similar security-related alert that prevents them from accessing securely to website which SSL is enabled with Let’s Encrypt.


How to know if this will affect you?

Open This Link on your browser.


If the page loads fine, your OS and web client support the root certificate, and there is no further action required.


If you are getting “this connection is not secure” or a similar security-related alert that prevents you from accessing the page, kindly use the latest version of OS or browsers other than the affected OS or Web clients listed above.


Please ensure to update your OS and browsers and please do not hesitate to contact us by email to support@exabytes.sg if you have any enquiries regarding this announcement Thank You!

Best Regards,


Support Team
......................................
Technical Support Department